Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Kronos MIDI has dissappeared on my Win 10 computer! (solved)

 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos
View previous topic :: View next topic  
Author Message
timg11
Senior Member


Joined: 04 Jun 2008
Posts: 300

PostPosted: Sat Apr 14, 2018 7:24 pm    Post subject: Kronos MIDI has dissappeared on my Win 10 computer! (solved) Reply with quote

The MIDI ports from the Kronos have suddenly disappeared from my Windows system. The computer is Windows 10 / 64 bit version 1709

The Kronos is still enumerated in USB. Under Sound, video, and game controllers, I see:
KORG KRONOS (KORG KRONOS)
KRONOS (USB Audio Device)

I tried multiple Windows applications that use MIDI, and they all showed my other MIDI devices, but not the Kronos.

I downloaded the latest USB drivers from korg.com and installed DrvTools_1_15_r23e.exe

I rebooted the computer, and restarted the Kronos - no change.

The Korg driver utility looks like this:



I tried 32 bit, 64 bit, and Both for MIDI in settings, but none of those settings worked.

It looks like this in USBDevView:




Here are the settings in Device Manager:


What is "Device Migrated"? What is KORGUMDS?
The full information is:

Code:
Device USB\VID_0944&PID_0203&MI_03\7&32df62c6&1&0003 was migrated.
Last Device Instance Id: USB\VID_0944&PID_0203&MI_03\7&32df62c6&1&0003
Class Guid: {4D36E96C-E325-11CE-BFC1-08002BE10318}
Location Path:
Migration Rank: 0x0
Present: false


What does it mean "Present: false"? What is not present?

Can anyone look at their USB settings in Windows 10 and see if there is any difference, or anything obviously wrong in mine?
I haven't changed anything, but Microsoft is always updating Windows, so maybe that is part of it?
Anybody else having issues with Windows updates?

Edit; taking the date of the "Device Migrated" event and cross checking in the system logs, I see that KB4090914 was applied that day.
Searching on that KB takes me to this article, which implies it may have USB issues.


Edit2; I tried uninstalling and re-installing the drivers - did not help.
While looking at the drivers, I found EzSetup64.exe in C:\Program Files (x86)\KORG\KORG USB-MIDI Driver. It runs "Korg MIDI Driver Setup Utility". I select the Kronos, and it reports "The Device Driver was not installed properly". Still no Kronos MIDI.

Edit3: In the same folder, I ran "K_CoInst64.exe" (Co-Installer). It didn't seem to do anything. However, I then ran EzSetup64.exe again, selected the Kronos, and this time it said "The Device Driver was installed properly". Sure enough the Kronos MIDI is back!
Sheesh - I spent most of a day working on this issue. IMHO, way to difficult. I went back to the driver download to see if I missed the "README.TXT". Install instructions are this:
Quote:
If you use Korg USB-MIDI Device except Grandstage:
Run DrvTools.exe to install.

I hope this helps someone else. More detailed instructions and troubleshooting guides for the driver would be helpful.
_________________
Kronos2 73, Presonus StudioLive, Sonar Platinum, Windows 10
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group