Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Weird Timing Issue

 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos
View previous topic :: View next topic  
Author Message
WVought
Junior Member


Joined: 12 Sep 2010
Posts: 91

PostPosted: Tue May 08, 2018 1:30 am    Post subject: Weird Timing Issue Reply with quote

I'm using my DAW (Sonar) to send a MIDI loop out to Kronos. However, Kronos (with KARMA on) has started playing at double speed. By this I mean Kronos plays twice as many notes as it should. It still keeps time with Sonar, but sounds frenetic.

If KARMA is off there is no problem.

On the Global p1 MIDI page there are 5 options for MIDI Clock. If set to Internal all is well. But if I select any of the other 4 options and KARMA is on then this issue will appear.

I have Sonar set to send MIDI Clock to the Kronos.

While typing this I decided to load the same MIDI into Cubase and see if the problem persisted...it does not. I can send the same MIDI to Kronos and, with KARMA on, the loop will sound properly.

So it looks like a Sonar issue, but I'm posting this here in hopes that someone may have an idea as to the cause.
Back to top
View user's profile Send private message
19naia
Platinum Member


Joined: 29 Nov 2012
Posts: 878

PostPosted: Tue May 08, 2018 2:25 am    Post subject: Reply with quote

Is Sonar set to use its own midi clock?

Also, what channel is it sending on?
Is it sending on Omni channel?
Is it sending on a channel that Karma is using?

If a Karma module or more is/are set to a midi channel that the midi loop is sending on, then karma will take it in as note information and also process it through any GE that is active.
In fact, if a loop or rythm pattern were sent over midi channel used by Karma and then the Karma GE further processing or driving its own midi pattern into the incoming midi pattern, it would be working perfectly if it played at the very least, twice as many notes.
Karma is likely arpeggiating each note in the rythm pattern loop or whatever kind of loop it is.

Remember Karma is an Arpeggiator at its very basic level, and that means it takes one note input and outputs any of a huge number of multiple note combinations. A loop is sending a patterned series of midi notes, not just one. Karma will do its best to double each note if the rhythm spacing permits.

Karma is doing what it is supposed to do and thats why you hear twice as many notes. Other GE’s or GE parameter configurations could possibly make it more than twice as many notes or less than twice as many.

The likely reason why it does not happen on Cubase is that Cubase midi channel has some different setting.
Maybe Sonar is transmitting midi on all channels and cubase is only on kronos global channel. ?

Check the midi channel settings on Cubase and Sonar for comaprison. If they are exactly the same, then maybe that is a strange case you have, or a midi bypass somewhere.

As far as double notes when Karma is on, that is exactly what should happen when you send midi notes into Karma while a note-multiplying-configuration GE is active.
Why it is not happening in Cubase is where you should be looking.
Back to top
View user's profile Send private message
WVought
Junior Member


Joined: 12 Sep 2010
Posts: 91

PostPosted: Tue May 08, 2018 2:53 am    Post subject: Reply with quote

Sonar is using its own MIDI Clock.

It is sending MIDI via Channel 1, which is the Global Channel.

I've been using the Kronos for years now, and while I by no means consider myself a power user, I do understand that Kronos is an arpeggiator and that sending it even one note may result in many additional notes being output via KARMA.

What I have is a situation where MIDI data sent from Cubase causes KARMA to play correctly, but the same MIDI data sent from Sonar (at the same tempo) causes KARMA to play at double speed.

Obviously there is a sense in which KARMA is doing exactly what it is supposed to do. Sonar is somehow telling KARMA to generate twice as many notes. However, this sounds horrible, and I'd like to find some way to stop Sonar from doing this.

Thank you anyway.
Back to top
View user's profile Send private message
SeedyLee
Platinum Member


Joined: 13 Sep 2006
Posts: 1027
Location: Perth, Australia

PostPosted: Tue May 08, 2018 3:17 am    Post subject: Reply with quote

This can also happen if you have a MIDI loop somewhere in your MIDI configuration, which can cause the MIDI Beat Clock sent be SONAR to be duplicated. How is your Kronos connected to your PC?
_________________
Message me on BlackBerry Messenger: 2B3628BE
Current Equipment:
Korg Kronos 61, , Monotron, , Roland JV-80 & JV-1080 Kawai L1, Lexicon MX200, Motu 828 mk3, Presonus FaderPort, Motu MicroLite, Behringer BCR2000, Yamaha QY70, VocalWorks+, Rode NT1-A, Tascam VLX5 Monitors Tascam CD Player, Shure SRH840 Headphones. Shure IEM, Shure SM58, JBL PRX12 monitor wedge.

Previous: Triton LE 61/Sampling/64MB/4GB SCSI, MS2000BR, Monotribe, NanoKontrol, NanoKeys, Kaossilator II, Casio HT3000
Back to top
View user's profile Send private message
WVought
Junior Member


Joined: 12 Sep 2010
Posts: 91

PostPosted: Tue May 08, 2018 3:36 am    Post subject: Reply with quote

The Kronos is connected to my computer via USB. I'm using the driver supplied by Korg.

It's also connected via an out from my audio interface, using a MIDI cable. At the moment I'm not sure why I hooked that up. Anyway, I unplugged that cable and the problem remains.

I'm also using LoopBe30 for additional virtual MIDI ports. It is supposed to be able to detect and disable MIDI loops. It has a checkbox called "Enable Shortcut Detection," and I have that box checked.

But I think your suggestion makes sense, and has perhaps set me on the right track. Thanks.
Back to top
View user's profile Send private message
19naia
Platinum Member


Joined: 29 Nov 2012
Posts: 878

PostPosted: Tue May 08, 2018 3:48 am    Post subject: Reply with quote

WVought wrote:
Sonar is using its own MIDI Clock.

It is sending MIDI via Channel 1, which is the Global Channel.

I've been using the Kronos for years now, and while I by no means consider myself a power user, I do understand that Kronos is an arpeggiator and that sending it even one note may result in many additional notes being output via KARMA.

What I have is a situation where MIDI data sent from Cubase causes KARMA to play correctly, but the same MIDI data sent from Sonar (at the same tempo) causes KARMA to play at double speed.

Obviously there is a sense in which KARMA is doing exactly what it is supposed to do. Sonar is somehow telling KARMA to generate twice as many notes. However, this sounds horrible, and I'd like to find some way to stop Sonar from doing this.

Thank you anyway.


Maybe there is a loop back of Karma sending its GE notes out and that somehow goes to sonar and comes back into Kronos.
SeedyLee commented about Loop back. It woud have to be from Karma because it only happens when Karma is on.
I actaully have to set my midi clock in global to Auto USB to sync Karma with external midi patterns coming into kronos. I keep the external midi pattern on a channel isolated from what drumtrack uses, what karma uses and isolated from Global midi channel.

I am now not sure i can help, but i am wondering if Sonar and Cubase have an equivalent setting, like your kronos Midi clock setting? Are they set to Auto midi?
Sonar could have a stray midi message in it that sends when you play the midi data. A midi message that affects karma. Kronos sequencer also automatically sends out some midi messages in tandem everytime you press play or locate.
Maybe sonar has some midi messages transmitted like that or even a means to choose which messages are enabled or disabled. ?

Thanks, not sure i can be any help. I am more curious now than i am able to come up with clues.
Back to top
View user's profile Send private message
WVought
Junior Member


Joined: 12 Sep 2010
Posts: 91

PostPosted: Tue May 08, 2018 3:50 am    Post subject: Reply with quote

OK, I went into the Sonar preferences and unchecked the boxes which cause MIDI Clock to be sent to Kronos and to my audio interface. So nothing should be getting MIDI Clock. Then I pressed play in Sonar, and KARMA played, and it played correctly.

I'm not sure what to make of this.
Back to top
View user's profile Send private message
WVought
Junior Member


Joined: 12 Sep 2010
Posts: 91

PostPosted: Tue May 08, 2018 3:53 am    Post subject: Reply with quote

"Maybe there is a loop back of Karma sending its GE notes out and that somehow goes to sonar and comes back into Kronos. "

Yes, probably some sort of loop, but this is a head scratcher.
Back to top
View user's profile Send private message
19naia
Platinum Member


Joined: 29 Nov 2012
Posts: 878

PostPosted: Tue May 08, 2018 3:24 pm    Post subject: Reply with quote

WVought wrote:
"Maybe there is a loop back of Karma sending its GE notes out and that somehow goes to sonar and comes back into Kronos. "

Yes, probably some sort of loop, but this is a head scratcher.


You did say that when you set global midi clock settings to internal, no problems occur. When you set it to any other, then problems.

I have stray message issues when i use Auto midi setting rather than internal. I Use Auto midi to coordinate controls between kronos and drum machine. Both devices set to auto midi and i can stop drum machine with a peadal and that same message stops karma and drum machine and sequencer. Auto midi lets me do that but not when set to internal.
Down side is i get unwanted messages sent from time to time because of midi filter lack or maybe i just never found the right midi filter on drum machine or my iPad.

What auto midi does is lets both devices have open flow for transmit and recieve. And between them, they decide which one’s clock to follow.
If both clocks have different tempo settings, one will be ignored and in my case, Kronos gets ignored because the drum machine is the driver and generates the midi notes kronos plays. I have them both linked with midi In and midi Out cables.
If they both sent their midi clocks together, thier metronome timing calibration may not be an exact match, being from different companies. And a slight ripple in the pattern could happen.
I have iPad connected over kronos USB midi and it gets stray messages sometimes from drum machine because iPad picks up on all channels and i suspect is in constant auto midi state.

Maybe a loop back in your case, but i am not sure exactly.
Glad you cleared it up and back on track.
Back to top
View user's profile Send private message
WVought
Junior Member


Joined: 12 Sep 2010
Posts: 91

PostPosted: Tue May 08, 2018 3:37 pm    Post subject: Reply with quote

I wouldn't exactly say I got it cleared up. It's still a mystery. Disabling MIDI Clock to Kronos is a workaround, and I don't understand what's causing the issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group