Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Logic/Mac - Kronos audio and Midi question

 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos
View previous topic :: View next topic  
Author Message
PaulyV



Joined: 13 Mar 2018
Posts: 9

PostPosted: Mon Oct 29, 2018 10:33 pm    Post subject: Logic/Mac - Kronos audio and Midi question Reply with quote

Hello there,

I can see this has been discussed before however I struggle to find a clear answer to my specific, but I suspect very basic, question.

I have a Kronos, and a Mac running Logic. I have installed the Kronos drivers on the Mac and it is visible in the Audio Midi Setup program. I have connected the Kronos to the Mac via USB.

Could I ask what my settings should be on both Logic and the Kronos in order that:

a) My Kronos controls soft synths in Logic via midi.

b) The audio from these soft synths is output back into the Kronos (hence using it as an audio card) which is itself connected to my monitor speakers.

Thank you in advance, and apologies if I am missing something obvious here.
Back to top
View user's profile Send private message
Gunnar
Full Member


Joined: 27 Jan 2016
Posts: 139
Location: Norway

PostPosted: Tue Oct 30, 2018 5:12 am    Post subject: Reply with quote

Hi PaulyV,

I had a similar problem a few weeks ago when I wanted my Kronos connected via MIDI. This is something I haven't done in ages so I looked up the old posts as well. I'm currently running High Sierra.

It is rather counter intuitive, but to get the Kronos to show up as a MIDI device on your Mac you'll want to remove the Korg USB Midi driver. Yes, remove it Smile

You'll find it under /Library/Audio/MIDI Drivers.

Once you've done that, and then plug the Kronos USB back in, it should show up as a device if you open the OSX app "Audio MIDI Setup".

As for the USB Audio interface, this should "just works". Once the Kronos is plugged in, you should be able to pick the Kronos as an input / output device under "System Preferences". You don't need to pick it as an option there, but if you see it, you know its working.

I don't use Logic, but once the Kronos USB Audio is working in the system, you should be able to select that as your input / output device, and then you're set.

You'll need to set up Audio routing on the Kronos to route the USB out back to Kronos' outputs L & R.
_________________
Gear: Korg Kronos 2 73, Arturia Microbrute & MiniBrute 2, Moog Mother-32, Ibanez RG320DXFM Guitar, ESP Viper 254FM Bass, Blackstar HT-1
Software: Reaper, EZ Drummer
Soundcloud: https://soundcloud.com/gunnarsletta
Back to top
View user's profile Send private message
PaulyV



Joined: 13 Mar 2018
Posts: 9

PostPosted: Tue Oct 30, 2018 2:33 pm    Post subject: Reply with quote

Thank you Gunnar, I appreciate you taking the time to reply. I will give that a go.

Aside from the Midi I have never used my Kronos as an audio card. I will look up some details tonight but if you have familiarity with how to do the below I would appreciate a couple of pointers?

You'll need to set up Audio routing on the Kronos to route the USB out back to Kronos' outputs L & R.
Back to top
View user's profile Send private message
Gunnar
Full Member


Joined: 27 Jan 2016
Posts: 139
Location: Norway

PostPosted: Tue Oct 30, 2018 4:48 pm    Post subject: Reply with quote

PaulyV wrote:
...
Aside from the Midi I have never used my Kronos as an audio card. I will look up some details tonight but if you have familiarity with how to do the below I would appreciate a couple of pointers?

You'll need to set up Audio routing on the Kronos to route the USB out back to Kronos' outputs L & R.


Sure, in either PROG, COMBI or SEQ mode, find the "Audio In / Sampling" tab under the "Play" tab. There is a checkbox in the upper left corner to use the Global settings or not, uncheck that for now. Then set the "Bus Select (IFX/Indiv)" for "USB 1" to L/R and similar for "USB 2". You've now routed the Kronos USB audio input directly to the Kronos L/R bus so sounds from the computer should now sound out of the headphones.

These settings are now for the PROG, COMBI or SEQ in question. If you want to set things up like this for all patches globally, do the same thing under GLOBAL (and in that case, you want to have the "use global" checkbox checked).

Now.. The problem with this setup is that when you start to record, the playback from the DAW will go through the L/R bus, just like the main sounds from the Kronos, so you can't really use it for recording. To solve this problem, you need an external mixer, or to not use the Kronos as output interface for your computer. Easiest solution is if you have an external mixer. Under the "Audio In / Sampling" route the USB inputs 1&2 to the 1 & 2 busses instead, and plug cables from the 1 & 2 outputs on the back of the Kronos into your mixer along with the ones coming from the L&R outputs. That gives you a separated signal and an all digital signal path to and from the Kronos.

I ran with this setup before I got my current audio interface.

Good Luck Smile
_________________
Gear: Korg Kronos 2 73, Arturia Microbrute & MiniBrute 2, Moog Mother-32, Ibanez RG320DXFM Guitar, ESP Viper 254FM Bass, Blackstar HT-1
Software: Reaper, EZ Drummer
Soundcloud: https://soundcloud.com/gunnarsletta
Back to top
View user's profile Send private message
Xenophile
Junior Member


Joined: 14 Nov 2017
Posts: 85

PostPosted: Tue Oct 30, 2018 7:49 pm    Post subject: Reply with quote

Gunnar wrote:
The problem with this setup is that when you start to record, the playback from the DAW will go through the L/R bus, just like the main sounds from the Kronos, so you can't really use it for recording. To solve this problem, you need an external mixer, or to not use the Kronos as output interface for your computer. Easiest solution is if you have an external mixer. Under the "Audio In / Sampling" route the USB inputs 1&2 to the 1 & 2 busses instead, and plug cables from the 1 & 2 outputs on the back of the Kronos into your mixer along with the ones coming from the L&R outputs. That gives you a separated signal and an all digital signal path to and from the Kronos.

I've been wrestling with the same issue.
I would think with the above solution, you might not want to listen to the Kronos main L/R outputs directly... But only through Logic. Otherwise you may be hearing both, leading to weird doubling/delay/phasing effects and confusion when you're trying to mix down a project.

Another downside is that the Kronos headphone output is hard-wired to its main L/R outputs, so you won't hear the computer's output through the Kronos headphone output... Only through the 1 & 2 outputs on the back.

There are trade-offs no matter which way you go.
Back to top
View user's profile Send private message
PaulyV



Joined: 13 Mar 2018
Posts: 9

PostPosted: Tue Oct 30, 2018 11:17 pm    Post subject: Reply with quote

Thank you all - that's really useful and I will have a go this weekend.

Appreciate you taking the time.

Pauly
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group