Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

KRONOS Fan Information
Goto page Previous  1, 2, 3 ... 22, 23, 24
 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos
View previous topic :: View next topic  
Author Message
SeedyLee
Platinum Member


Joined: 13 Sep 2006
Posts: 1116
Location: Perth, Australia

PostPosted: Sun Apr 28, 2019 10:56 am    Post subject: Reply with quote

During a recent service of my 2011 Kronos, I decided to replace the fan as the factory unit was becoming progressively noisier. (Incidentally, the stock fan is rated for around 30,000 hours of use). Like a few others, I tried the Noctua NF-A6X25 FLX as it was readily available in my region and should be a high quality fan.

I found this fan was still quite noisy on "Auto" mode, but on "Slow" it didn't seem to move enough air to keep temperatures low. On my unit, temperatures were getting up to 80 degrees in a 29 degree room. On auto, the fan speed was much higher, but it still wasn't full speed. It also made an annoying humming sound due to the pulse width modulation.

I entered test mode (Hold Mixer Knobs, Reset Controls, Enter, 2) and actually found it to be quieter on higher fan speeds.

What I discovered is that the Kronos controls fan speed using its own algorithm in the EVA module, and it uses preset fan PWM values that work reasonable well with the stock fan, but don't necessarily work optimally with aftermarket fans. It updates the fan speed about once a second between two values.

I modified my Kronos to use the native Linux WinBond fan speed control algorithm instead, by (essentially) adding these two lines to my inittab:

Code:
# Adjust fan control settings
echo 3 > /sys/devices/platform/w83627hf.656/pwm1_enable
echo [b]68000[/b] > /sys/devices/platform/w83627hf.656/temp1_max


This configures the Linux kernel to ignore the PWM control value issued by the Korg EVA application, and instead target a maximum system (not CPU) temperature of 68 degrees.

It's also possible to manually set the fan speed using a similar technique, however once we set the fan speed manually, we have to prevent EVA from overridding it (the chmod 666 prevents the EVA process from updating the fan speed)

Code:

# Adjust fan speed manually
echo 1 > /sys/devices/platform/w83627hf.656/pwm1_enable
echo [b]240[/b] > /sys/devices/platform/w83627hf.656/pwm1; chmod 666 /sys/devices/platform/w83627hf.656/pwm1

I found values between 110 and 240 were reasonable - 110 equated to the default "Slow" setting on the original Kronos, and 176 was the default "auto" speed. 255 should be full speed.

Note that after making these changes, the fan speed can't be changed via the Kronos UI any longer.

If anyone is interested in this, I can potentially look at bundling it up to an unofficial Kronos update (this should be fine legally speaking as doing so doesn't involve reverse engineering or modifying any Korg binaries or code). Let me know!
_________________
Message me on BlackBerry Messenger: 2B3628BE
Current Equipment:
Korg Kronos 61, , Monotron, , Roland JV-80 & JV-1080 Kawai L1, Lexicon MX200, Motu 828 mk3, Presonus FaderPort, Motu MicroLite, Behringer BCR2000, Yamaha QY70, VocalWorks+, Rode NT1-A, Tascam VLX5 Monitors Tascam CD Player, Shure SRH840 Headphones. Shure IEM, Shure SM58, JBL PRX12 monitor wedge.

Previous: Triton LE 61/Sampling/64MB/4GB SCSI, MS2000BR, Monotribe, NanoKontrol, NanoKeys, Kaossilator II, Casio HT3000
Back to top
View user's profile Send private message
GregC
Platinum Member


Joined: 15 May 2002
Posts: 7732
Location: Discovery Bay (San Francisco Bay Area)

PostPosted: Sun Apr 28, 2019 4:07 pm    Post subject: Reply with quote

SeedyLee wrote:
During a recent service of my 2011 Kronos, I decided to replace the fan as the factory unit was becoming progressively noisier. (Incidentally, the stock fan is rated for around 30,000 hours of use). Like a few others, I tried the Noctua NF-A6X25 FLX as it was readily available in my region and should be a high quality fan.

I found this fan was still quite noisy on "Auto" mode, but on "Slow" it didn't seem to move enough air to keep temperatures low. On my unit, temperatures were getting up to 80 degrees in a 29 degree room. On auto, the fan speed was much higher, but it still wasn't full speed. It also made an annoying humming sound due to the pulse width modulation.

I entered test mode (Hold Mixer Knobs, Reset Controls, Enter, 2) and actually found it to be quieter on higher fan speeds.

What I discovered is that the Kronos controls fan speed using its own algorithm in the EVA module, and it uses preset fan PWM values that work reasonable well with the stock fan, but don't necessarily work optimally with aftermarket fans. It updates the fan speed about once a second between two values.

I modified my Kronos to use the native Linux WinBond fan speed control algorithm instead, by (essentially) adding these two lines to my inittab:

Code:
# Adjust fan control settings
echo 3 > /sys/devices/platform/w83627hf.656/pwm1_enable
echo [b]68000[/b] > /sys/devices/platform/w83627hf.656/temp1_max


This configures the Linux kernel to ignore the PWM control value issued by the Korg EVA application, and instead target a maximum system (not CPU) temperature of 68 degrees.

It's also possible to manually set the fan speed using a similar technique, however once we set the fan speed manually, we have to prevent EVA from overridding it (the chmod 666 prevents the EVA process from updating the fan speed)

Code:

# Adjust fan speed manually
echo 1 > /sys/devices/platform/w83627hf.656/pwm1_enable
echo [b]240[/b] > /sys/devices/platform/w83627hf.656/pwm1; chmod 666 /sys/devices/platform/w83627hf.656/pwm1

I found values between 110 and 240 were reasonable - 110 equated to the default "Slow" setting on the original Kronos, and 176 was the default "auto" speed. 255 should be full speed.

Note that after making these changes, the fan speed can't be changed via the Kronos UI any longer.

If anyone is interested in this, I can potentially look at bundling it up to an unofficial Kronos update (this should be fine legally speaking as doing so doesn't involve reverse engineering or modifying any Korg binaries or code). Let me know!


very impressed by all your work 'inside ' Kronos.

By 'EVA module ', are you referring to Kronos PSU or internal power supply ?
_________________
Kronos 88. nanoPAD2. Roland FA-07, MBP, UR44
Achieve your musical dreams Smile
https://soundcloud.com/user-898236994
Back to top
View user's profile Send private message Send e-mail
SeedyLee
Platinum Member


Joined: 13 Sep 2006
Posts: 1116
Location: Perth, Australia

PostPosted: Mon Apr 29, 2019 6:40 am    Post subject: Reply with quote

GregC wrote:
SeedyLee wrote:
During a recent service of my 2011 Kronos, I decided to replace the fan as the factory unit was becoming progressively noisier. (Incidentally, the stock fan is rated for around 30,000 hours of use). Like a few others, I tried the Noctua NF-A6X25 FLX as it was readily available in my region and should be a high quality fan.

I found this fan was still quite noisy on "Auto" mode, but on "Slow" it didn't seem to move enough air to keep temperatures low. On my unit, temperatures were getting up to 80 degrees in a 29 degree room. On auto, the fan speed was much higher, but it still wasn't full speed. It also made an annoying humming sound due to the pulse width modulation.

I entered test mode (Hold Mixer Knobs, Reset Controls, Enter, 2) and actually found it to be quieter on higher fan speeds.

What I discovered is that the Kronos controls fan speed using its own algorithm in the EVA module, and it uses preset fan PWM values that work reasonable well with the stock fan, but don't necessarily work optimally with aftermarket fans. It updates the fan speed about once a second between two values.

I modified my Kronos to use the native Linux WinBond fan speed control algorithm instead, by (essentially) adding these two lines to my inittab:

Code:
# Adjust fan control settings
echo 3 > /sys/devices/platform/w83627hf.656/pwm1_enable
echo [b]68000[/b] > /sys/devices/platform/w83627hf.656/temp1_max


This configures the Linux kernel to ignore the PWM control value issued by the Korg EVA application, and instead target a maximum system (not CPU) temperature of 68 degrees.

It's also possible to manually set the fan speed using a similar technique, however once we set the fan speed manually, we have to prevent EVA from overridding it (the chmod 666 prevents the EVA process from updating the fan speed)

Code:

# Adjust fan speed manually
echo 1 > /sys/devices/platform/w83627hf.656/pwm1_enable
echo [b]240[/b] > /sys/devices/platform/w83627hf.656/pwm1; chmod 666 /sys/devices/platform/w83627hf.656/pwm1

I found values between 110 and 240 were reasonable - 110 equated to the default "Slow" setting on the original Kronos, and 176 was the default "auto" speed. 255 should be full speed.

Note that after making these changes, the fan speed can't be changed via the Kronos UI any longer.

If anyone is interested in this, I can potentially look at bundling it up to an unofficial Kronos update (this should be fine legally speaking as doing so doesn't involve reverse engineering or modifying any Korg binaries or code). Let me know!


very impressed by all your work 'inside ' Kronos.

By 'EVA module ', are you referring to Kronos PSU or internal power supply ?



Eva is the name of the application on the Kronos that provides the user interface and overall system control, as far as I can tell. It runs in userspace, whereas the sound generation components run as an extension of the kernel.

I found that the Kernel module for the WinBond controller actually doesn't do fan speed control on the Kronos, so I'm thinking of putting together a little C utility to do simple PID fan control, possibly based on one of the existing Linux fan control daemons. Interestingly, the Kronos includes a stub of a fan controller, but it doesn't actually do anything.
_________________
Message me on BlackBerry Messenger: 2B3628BE
Current Equipment:
Korg Kronos 61, , Monotron, , Roland JV-80 & JV-1080 Kawai L1, Lexicon MX200, Motu 828 mk3, Presonus FaderPort, Motu MicroLite, Behringer BCR2000, Yamaha QY70, VocalWorks+, Rode NT1-A, Tascam VLX5 Monitors Tascam CD Player, Shure SRH840 Headphones. Shure IEM, Shure SM58, JBL PRX12 monitor wedge.

Previous: Triton LE 61/Sampling/64MB/4GB SCSI, MS2000BR, Monotribe, NanoKontrol, NanoKeys, Kaossilator II, Casio HT3000
Back to top
View user's profile Send private message
SeedyLee
Platinum Member


Joined: 13 Sep 2006
Posts: 1116
Location: Perth, Australia

PostPosted: Sun May 05, 2019 4:49 am    Post subject: Reply with quote

Okay, so a little more information about fan control on the Kronos.

The speed (and hance noise) of the fan is controlled by a Winbond W83627THG-I Super I/O controller using pulse width modulation (PWM). This is controlled by the Linux W83627HF driver, the source code for which can be found here: https://github.com/torvalds/linux/blob/master/drivers/hwmon/w83627hf.c

The Winbond controller has two registers which directly affect the mechanical performance of the fan: PWM width (or duty cycle), and PWM frequency. It appears only PWM Width can be adjusted at runtime via the sysfs on the Kronos - PWM frequency is hardcoded to a static value. Unfortunately, depending on the fan, the PWM Frequency may not be optimal and may produce harmonic noise (buzzing etc).

If your aftermarket fan is humming or buzzing, it may be because the PWM Frequency isn't suitable for the mechanical characteristics of that fan. The easiest option is probably to adjust the fan speed electrically using a resistor in serial, and run it at a duty cycle as close to 100% as possible.

It's also worth mentioning that the minimum speed via PWM control differs from fan to fan, so some fans may stop when the Kronos is set to "Slow" fan control.

My advice: stick with the stock fan. Other fans may appear to have similar performance characteristics, but the Kronos works optimally with the factory fan from a noise perspective.
_________________
Message me on BlackBerry Messenger: 2B3628BE
Current Equipment:
Korg Kronos 61, , Monotron, , Roland JV-80 & JV-1080 Kawai L1, Lexicon MX200, Motu 828 mk3, Presonus FaderPort, Motu MicroLite, Behringer BCR2000, Yamaha QY70, VocalWorks+, Rode NT1-A, Tascam VLX5 Monitors Tascam CD Player, Shure SRH840 Headphones. Shure IEM, Shure SM58, JBL PRX12 monitor wedge.

Previous: Triton LE 61/Sampling/64MB/4GB SCSI, MS2000BR, Monotribe, NanoKontrol, NanoKeys, Kaossilator II, Casio HT3000
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Kronos All times are GMT
Goto page Previous  1, 2, 3 ... 22, 23, 24
Page 24 of 24

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group