Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Dead Wavedrum X. Any ideas?

 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Wavedrum
View previous topic :: View next topic  
Author Message
trubright



Joined: 13 Apr 2011
Posts: 4
Location: St. Louis, MO

PostPosted: Sat Jan 24, 2015 6:57 pm    Post subject: Dead Wavedrum X. Any ideas? Reply with quote

I have a first generation Wavedrum X that's full of original patches. It won't turn on and is completely dead. I bought a new external power supply, hoping that was the problem, but no joy. Has anyone has this problem or, better yet, fixed it? Thanks in advance for any ideas.
Back to top
View user's profile Send private message Visit poster's website
martygras
Junior Member


Joined: 22 Jun 2011
Posts: 84
Location: Southern Oregon USA

PostPosted: Tue Feb 03, 2015 11:14 pm    Post subject: Reply with quote

Since it is not under any warranty now, you can open these up pretty easily without breaking anything. Check the power jack to see if it has a loose solder joint or if the PC board is discolored in some locations this could be a burnt component.
How good are your soldering skills?
Back to top
View user's profile Send private message
trubright



Joined: 13 Apr 2011
Posts: 4
Location: St. Louis, MO

PostPosted: Fri Feb 06, 2015 5:35 pm    Post subject: It's fixed! Reply with quote

I took it apart but saw nothing obvious so I searched for a local Korg tech online and took it in. They were able to fix it, which I'm happy about. When I pick it up I'll find out what the happened and post it here in case anyone else has the same problem Very Happy
Back to top
View user's profile Send private message Visit poster's website
yoshi88
Junior Member


Joined: 27 Apr 2007
Posts: 84

PostPosted: Sat Oct 08, 2016 3:40 am    Post subject: Re: It's fixed! Reply with quote

trubright wrote:
I took it apart but saw nothing obvious so I searched for a local Korg tech online and took it in. They were able to fix it, which I'm happy about. When I pick it up I'll find out what the happened and post it here in case anyone else has the same problem Very Happy


HOw did you take it apart? Removing the head first?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Wavedrum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group