Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fatal Error in Sonar 7 Studio Edition.

 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Legacy Collection
View previous topic :: View next topic  
Author Message
Chez Jonesy



Joined: 15 May 2008
Posts: 1

PostPosted: Thu May 15, 2008 6:39 pm    Post subject: Fatal Error in Sonar 7 Studio Edition. Reply with quote

Hi there.

I recently upgraded to Sonar 7 SE from Home Studio 6 XL.

One of my vst's is the Kork Legacy Collection, which includes four vst instruments:

1) Wavestation
2) the MS-20
3) the Poly Six
and
4) The Legacy Suite, which is a really nice combination of the MS-20 and Poly 6 in the Legacy environment, complete with a boat load of nice patches.

Here is the problem: if i load the synth rack, then try to load items 1, 2, or 3 above, they all work fine, but if i try to load the Legacy vsti, Sonar gives me a Fatal error message, citing a file called MS-20.dll (note: each of the items 1-4 has its own dll file in the vst folder). This seems weird, as the MS-20 vsti works fine, but it is the ms-20.dll file that the fatal error refers to when i try to load the Legacy vsti.

If I try to open a project where the Legacy vsti is one of the instruments, i get the fatal error right away.

Everything worked fine when I was running Home Studio 6 XL, so I'm wondering what might have changed.

Is there a setting I can adjust to eliminate the fatal error?
Anyone else run into this issue?
What causes a fatal error?

Thanks in advance for any help you can provide.

CJ
_________________
visit www.chezjonesy.com.
four albums and lots of tunes on-line.
all tracks are free, downloadable, and streamable.
also, check out the Moon Tunes section for some great jam session recordings.
Pent 4, 3.4 Ghz, 2 gig ram
Back to top
View user's profile Send private message
MartinHines
Platinum Member


Joined: 21 Jan 2003
Posts: 2990
Location: Topeka, KS (USA)

PostPosted: Fri May 16, 2008 7:48 pm    Post subject: Reply with quote

I don't know what the problem could be.

When you run KLC within Sonar, you are using the VST versions of the plugin wherever you have installed them. For example mine are stored in C:\Program Files\VSTPlugins\Korg

Given you can successfully load/run all of the various .dlls (e.g. MS-20.dll, Polysix.dll) but run into trouble when you try to load the Legacy Cell app (LegacyCell.dll), I assume the problem is with that plugin.

I would try three different things.

1) Most current KLC versions

Go to www.Korguser.net and make sure you have the most current versions installed.

2) Install the most current version of the Syncrosoft License Control Center (LCC) application:
http://www.syncrosoft.com/Support-78-11.html

3) Rescan VST Plugins
Sometimes I get the impression that Sonar gets "confused" about VST plugins (most likely some internal table or registry entries).

Whenever I have trouble in Sonar with any VSTs, I force Sonar to "re-scan" all of my VST plugins. In Sonar:
-- "Tools", then "Cakewalk Plugin Manager"
-- Under "VST Configuration" click "Options"
-- You will see a screen with all of the "VST Scan paths". Write these all down, then "Remove" them all, then "Add" them back in
-- This should cause Sonar to re-scan all of the VST plugins creating new internal entries for them all.

If all of the above fails, contact Korg Product Support. There simply could be a problem with how Legacy Cell works with Sonar 7.
Back to top
View user's profile Send private message Send e-mail
StAnft
Junior Member


Joined: 11 Sep 2004
Posts: 70
Location: Hamburg, Germany

PostPosted: Sun May 18, 2008 10:51 pm    Post subject: Reply with quote

You should install the latest patch (I think it's 7.0.2). The problem you described was reported at the Sonar forums some time ago, and as far as I know this issue has been fixed in the latest update from Cakewalk.

Regards,
Stephan
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Legacy Collection All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group