Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Wavestation 1.7.0 crashes Logic Pro X
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Legacy Collection
View previous topic :: View next topic  
Author Message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1455

PostPosted: Wed Sep 25, 2013 6:27 pm    Post subject: Reply with quote

Its funny, I have tried again repeatedly to get it to crash and it just won't now, it must be some timing issue that is more noticeable on certain machines.
Back to top
View user's profile Send private message
kurt



Joined: 10 Jun 2006
Posts: 20

PostPosted: Mon Sep 30, 2013 3:29 pm    Post subject: Reply with quote

did someone had a reply from support about this bug ? I only got an automatic reply.
Back to top
View user's profile Send private message
kurt



Joined: 10 Jun 2006
Posts: 20

PostPosted: Wed Oct 09, 2013 4:05 pm    Post subject: Reply with quote

bump
Back to top
View user's profile Send private message
Mystic



Joined: 01 Nov 2012
Posts: 30

PostPosted: Sat Nov 09, 2013 10:12 pm    Post subject: Reply with quote

I saw this a couple of times right after Logic Pro X was released, but haven't seen it for a while now either. I wonder if it was addressed by one of the LPX patches? Is anyone still seeing this crash happen with LPX 10.0.4?
Back to top
View user's profile Send private message
dcafarelli



Joined: 23 Sep 2013
Posts: 2

PostPosted: Sun Dec 08, 2013 3:48 pm    Post subject: Wavestation 1.7.0 crashes Logic Pro X Reply with quote

I have had this same problem where Wavestation Legacy Plugin "occasionally" crashes Mainstage 2 and Mainstage 3 when loading a concert that uses the Wavestation plugin. I have had to eliminate using Wavestation Legacy plugins in my Concert configurations for reliable operation. The M1 Legacy Plugin does not have the same issue. I assume that the issue with crashing Logic X is similar to Mainstage 2/3. Has anyone had an issue with the M1 Legacy plugin?

If it were more reliable, I would use Wavestation plugin because I love the sounds that it has available when it works.

I could post a crash report but it is similar in that it shows that the crash occurs in the Wavestation VST which I assume is executing within an AU wrapper.
_________________
Dominick
Back to top
View user's profile Send private message
ffx
Junior Member


Joined: 02 Feb 2012
Posts: 86

PostPosted: Wed Apr 05, 2017 6:23 am    Post subject: Reply with quote

Double post Embarassed

Last edited by ffx on Wed Apr 05, 2017 6:26 am; edited 1 time in total
Back to top
View user's profile Send private message
ffx
Junior Member


Joined: 02 Feb 2012
Posts: 86

PostPosted: Wed Apr 05, 2017 6:24 am    Post subject: Reply with quote

Guys,

If you want to find some more specific reason, add the exact macos version to each of your post.

As far as I can tell, the wavestation vst starting to constantly crash with the appearance of macos sierra 10.12.1. It still crashes on 10.12.4. It worked perfectly on 10.9.4 though.

Yes, all korg plug-ins use an au->vst wrapper, so since other korg plug-ins do still work, this can't be the reason (e.g. Newly introduced file access restrictions).

Now what you can try - if your daw supports it - is to either enable sandboxing for the plug-in or strip out the 64bit part of the universal binary using the terminal command "lipo", so your daw has to use its 32bit bridge (for logic x AFAIK only possible thru that 32 bit wrapper tool, forgot name).

http://stackoverflow.com/questions/5739262/how-do-i-remove-the-ppc-section-in-growl-framework
Back to top
View user's profile Send private message
mocando
Platinum Member


Joined: 21 Apr 2009
Posts: 1237
Location: Panama City, Panama

PostPosted: Sat Apr 15, 2017 2:53 am    Post subject: Reply with quote

I exhausted all possibilities of support from the forum, and whichever email address I could find to get my Wavestation work in MainStage 3. Is sad, since I'd love to use the instrument, but now I rely on samples. I used MS auto sampling functionality, and got the patches I need. It doesn't sound like the real thing, since the Wavestation have some very unique character, but there is nothing I can do.
And is not that I didn't tried hard. At first, it was only a few crashes, mostly when quitting MainStage, but at the end, it was crashing when opening. Try to open a very complex multi patch concert, which takes about 45 seconds to open, and then it crashes. You can get your band waiting for over 5 minutes trying to get the thing loaded up.

Very frustrating.

I'll be watching this thread closely, hoping for a fix.
_________________
Martin Ocando

Korg Gear: Wavestation, NanoKeys
Korg Software: KC Wavestation, iOS iWavestation
Non Korg: M-Audio Code 61 MIDI Controller, Nektar GX49 MIDI Controller
Music Computing: Macbook Pro with Touch Bar Mid 2016, Mainstage 3.3.2, High Sierra
Photo Gear: Olympus OM-D E-M1 & E-M10, 12-40mm f:2.8 Pro, 9-18mm f:4-5.6, 45mm f:1.8, Panasonic 35-100mm f:2.8 X, 20mm f:1.7, Samyang 7.5mm

Visit: KORG Fans :: Everything KORG Twitter: @korgfans
Back to top
View user's profile Send private message Visit poster's website
mocando
Platinum Member


Joined: 21 Apr 2009
Posts: 1237
Location: Panama City, Panama

PostPosted: Fri Feb 16, 2018 8:53 pm    Post subject: Reply with quote

Just as an update, last week I realized that KLC migrated to KC, and used the coupon to get the new version. My goodness, I was so excited. But to my dismay, is still crashing. Apparently not as often as 1.7.0, but I can't believe how long this software have been around, and they hasn't been able to fix it.

So far, it appears to be crashing only when I saved the concert with a patch containing the Wavestation was last selected. Now I have to take care to move to another patch before saving.

If those are the only occasion where the plugin will crash, I believe I can live with it.

Praying for stability.
_________________
Martin Ocando

Korg Gear: Wavestation, NanoKeys
Korg Software: KC Wavestation, iOS iWavestation
Non Korg: M-Audio Code 61 MIDI Controller, Nektar GX49 MIDI Controller
Music Computing: Macbook Pro with Touch Bar Mid 2016, Mainstage 3.3.2, High Sierra
Photo Gear: Olympus OM-D E-M1 & E-M10, 12-40mm f:2.8 Pro, 9-18mm f:4-5.6, 45mm f:1.8, Panasonic 35-100mm f:2.8 X, 20mm f:1.7, Samyang 7.5mm

Visit: KORG Fans :: Everything KORG Twitter: @korgfans
Back to top
View user's profile Send private message Visit poster's website
mocando
Platinum Member


Joined: 21 Apr 2009
Posts: 1237
Location: Panama City, Panama

PostPosted: Fri Feb 16, 2018 9:08 pm    Post subject: Reply with quote

Well, no. Is not just that. I was changing sample rate, and it crashed. In case someone might throw some light here, please check the first piece of the crash report:

Code:
Process:               MainStage 3 [14299]
Path:                  /Applications/MainStage 3.app/Contents/MacOS/MainStage 3
Identifier:            com.apple.mainstage3
Version:               3.3.2 (4685.60)
Build Info:            MAMainStage-4685060000000000~2
App Item ID:           634159523
App External ID:       823246637
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           MainStage 3 [14299]
User ID:               501

PlugIn Path:             /Library/Audio/Plug-Ins/VST/KORG/WAVESTATION.vst/Contents/MacOS/WAVESTATION
PlugIn Identifier:       jp.co.korg.wavestation_vst
PlugIn Version:          1.8.0 (1.8.0)

Date/Time:             2018-02-16 15:59:49.062 -0500
OS Version:            Mac OS X 10.13.4 (17E150g)
Report Version:        12
Bridge OS Version:     3.0 (14Y662)
Anonymous UUID:        8437B372-CDD0-A408-4B97-C437527C53ED

Sleep/Wake UUID:       EE1ED05E-8D87-4759-B13D-FB2B7DDD2D25

Time Awake Since Boot: 98000 seconds
Time Since Wake:       27000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00000000000000c4
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0xc4:
-->
    __TEXT                 0000000108b03000-0000000108f79000 [ 4568K] r-x/rwx SM=COW  /Applications/MainStage 3.app/Contents/MacOS/MainStage 3

Application Specific Information:
Performing @selector(applyChanges:) from sender MAKitButton 0x60c001f7f440

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   jp.co.korg.wavestation_vst       0x000000013ec27414 0x13eb65000 + 795668
1   jp.co.korg.wavestation_vst       0x000000013ec27929 0x13eb65000 + 796969
2   jp.co.korg.wavestation_vst       0x000000013ec2f643 0x13eb65000 + 828995
3   jp.co.korg.wavestation_vst       0x000000013ec1957e 0x13eb65000 + 738686
4   jp.co.korg.wavestation_vst       0x000000013eb660ea 0x13eb65000 + 4330
5   jp.co.korg.wavestation_vst       0x000000013ec325c6 0x13eb65000 + 841158
6   jp.co.korg.wavestation_au        0x000000013eabf749 KLLVSTPlugin::CreateAEffectFromVSTPluginFile(FSRef const&, bool&, __CFBundle*&, int&, __CFString const*) + 219
7   jp.co.korg.wavestation_au        0x000000013eabeb94 KLLVSTPlugin::LoadVSTPlugin(FSRef const&, __CFString const*) + 70
8   jp.co.korg.wavestation_au        0x000000013eabeac5 KLLVSTPlugin::KLLVSTPlugin(KLLVSTPluginDescriptor const&, int, __CFString const*) + 167
9   jp.co.korg.wavestation_au        0x000000013eab78c7 KLWrapperBase::CreateVSTInstanceFromVSTPlugin(__CFBundle*, int) + 1333
10  jp.co.korg.wavestation_au        0x000000013eab86f1 KLAUWrapper::Initialize() + 95
11  jp.co.korg.wavestation_au        0x000000013eacb0dd AUBase::DoInitialize() + 27
12  jp.co.korg.wavestation_au        0x000000013eab7d8a ComponentEntryPoint<KLAUWrapper>::Dispatch(ComponentParameters*, KLAUWrapper*) + 32
13  com.apple.audio.toolbox.AudioToolbox   0x00007fff3be4f89c AudioUnitInitialize + 346
14  com.apple.music.apps.MAAudioEngine   0x000000010a4c6b17 CMDAudioUnit::Load(long, long, long) + 3479
15  com.apple.music.apps.MAAudioEngine   0x000000010a497e70 MTEngine::NewPlug(CPlugIn**, short, long, long, long, bool) + 368
16  com.apple.music.apps.LogicPro    0x000000010b9c8277 0x10b853000 + 1528439
17  com.apple.music.apps.LogicPro    0x000000010b8d8c94 0x10b853000 + 547988
18  com.apple.music.apps.LogicPro    0x000000010b8d78b3 0x10b853000 + 542899
19  com.apple.music.apps.LogicPro    0x000000010b8d68b7 AudioCompile(int, TAudioCompileMode, short*, int) + 3735
20  com.apple.music.apps.LogicPro    0x000000010b8c1cb3 CheckAndInitAudioConf(CSong*, int) + 2563
21  com.apple.music.apps.LogicPro    0x000000010b9327df LaunchAudioDevice(int, bool) + 543
22  com.apple.music.apps.LogicPro    0x000000010b866530 LgAudioSetActiveDrivers + 240
23  com.apple.mainstage3             0x0000000108e11333 0x108b03000 + 3203891
24  com.apple.mainstage3             0x0000000108e12347 0x108b03000 + 3208007
25  com.apple.AppKit                 0x00007fff3b084306 -[NSApplication(NSResponder) sendAction:to:from:] + 312
26  com.apple.AppKit                 0x00007fff3ab29eaf -[NSControl sendAction:to:] + 86
27  com.apple.AppKit                 0x00007fff3ab29dd7 __26-[NSCell _sendActionFrom:]_block_invoke + 136
28  com.apple.AppKit                 0x00007fff3ab29cdd -[NSCell _sendActionFrom:] + 183
29  com.apple.AppKit                 0x00007fff3ab6af98 -[NSButtonCell _sendActionFrom:] + 97
30  com.apple.LogicUIKit             0x000000010943b8a9 0x109410000 + 178345
31  com.apple.LogicUIKit             0x000000010943b515 0x109410000 + 177429
32  com.apple.LogicUIKit             0x000000010943b07d 0x109410000 + 176253
33  com.apple.AppKit                 0x00007fff3ab26fe0 -[NSControl mouseDown:] + 965
34  com.apple.LogicUIKit             0x0000000109428bdb 0x109410000 + 101339
35  com.apple.AppKit                 0x00007fff3b223505 -[NSWindow(NSEventRouting) _handleMouseDownEvent:isDelayedEvent:] + 5891
36  com.apple.AppKit                 0x00007fff3b22015c -[NSWindow(NSEventRouting) _reallySendEvent:isDelayedEvent:] + 2359
37  com.apple.AppKit                 0x00007fff3b21f408 -[NSWindow(NSEventRouting) sendEvent:] + 497
38  com.apple.LogicUIKit             0x000000010950ce74 0x109410000 + 1035892
39  com.apple.AppKit                 0x00007fff3b0801c3 -[NSApplication(NSEvent) sendEvent:] + 307
40  com.apple.mainstage3             0x0000000108b2f807 0x108b03000 + 182279
41  com.apple.AppKit                 0x00007fff3a8e131d -[NSApplication run] + 812
42  com.apple.AppKit                 0x00007fff3a8b04c6 NSApplicationMain + 804
43  com.apple.mainstage3             0x0000000108b225e7 0x108b03000 + 128487
44  libdyld.dylib                    0x00007fff658dc015 start + 1

_________________
Martin Ocando

Korg Gear: Wavestation, NanoKeys
Korg Software: KC Wavestation, iOS iWavestation
Non Korg: M-Audio Code 61 MIDI Controller, Nektar GX49 MIDI Controller
Music Computing: Macbook Pro with Touch Bar Mid 2016, Mainstage 3.3.2, High Sierra
Photo Gear: Olympus OM-D E-M1 & E-M10, 12-40mm f:2.8 Pro, 9-18mm f:4-5.6, 45mm f:1.8, Panasonic 35-100mm f:2.8 X, 20mm f:1.7, Samyang 7.5mm

Visit: KORG Fans :: Everything KORG Twitter: @korgfans
Back to top
View user's profile Send private message Visit poster's website
Mr. Pete



Joined: 28 Sep 2013
Posts: 3

PostPosted: Sun Mar 18, 2018 12:24 am    Post subject: Re: resizeable 1.7.0 crashes Logic Pro X Reply with quote

SAME HERE WS is crashing intermittently on Logic 10.4.1 and OS 10.13 quite frequently - most often but not always on startup

M1 was acting a bit weird today, too (no sound in Logic- requiring a restart)


Was nice to see that the ARP Odyssey AU window is at least a tiny bit bigger then most of the other product line ~ but kind of shocked that none of the Korg Collection AU windows are resizeable yet - like the APPLE and ARTURIA ones which have been resizeable for years



MrKoala wrote:
Hello,

Since I installed the Wavestation Legacy 1.7.0, I have a random crash while opening Logic Pro X : it states the Wavestation module caused Logic to terminate unexpectedly.

[img]http://www.isothesis.com/images/crash_logic.tiff[/img]

Here's a screenshot of the error I get (sorry for the French but that's pretty clear anyway).

Oddly, Logic's AU Manager says the plugin is Wavestation 1.3.0. I've never had this early version installed.

I use Logic Pro X (10.0.1) with OSX 10.8.4 on a MacBook Pro 6,2. It seems I now have the same problem while opening Logic Pro 9.

Thanks in advance for any help Smile
Back to top
View user's profile Send private message
macmicke



Joined: 13 May 2018
Posts: 1

PostPosted: Sun May 13, 2018 10:29 am    Post subject: Reply with quote

So this is 2018 and im running on 10.13.3 with Logic Pro X 10.4.1, Korg Wavestation 1.7.2. And the problem persists. I tried contacting Korg in Sweden. But got nothing but a shitanswer. "have you tried restarting your computer". Does anybody got a solution to this problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Legacy Collection All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group