Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Monotron Delay - "Delay" part stopped working

 
Post new topic   Reply to topic    Korg Forums Forum Index -> KORG Monotron Series
View previous topic :: View next topic  
Author Message
evanowe



Joined: 07 Sep 2014
Posts: 1

PostPosted: Sun Sep 07, 2014 6:17 am    Post subject: Monotron Delay - "Delay" part stopped working Reply with quote

I dropped my monotron on the floor, and it has stopped function as usual - so basically I got just Monotron now, without the delay (feedback-time) part.
I disassembled the case but didn't see any physical damages to the PCB. But I'm noob in electronics.
What might happen and how can I fix it?
Back to top
View user's profile Send private message
andrezp



Joined: 23 Aug 2010
Posts: 3

PostPosted: Tue Jun 26, 2018 3:58 pm    Post subject: Reply with quote

sorry for the necro-bump, but I'm having this exact same problem. Disassembled the monotron and saw nothing wrong in the PCB. Any tips on this?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> KORG Monotron Series All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group