Korg Forums Forum Index Korg Forums
A forum for Korg product users and musicians around the world.
Moderated Independently.
Owned by Irish Acts Recording Studio & hosted by KORG USA
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Wavestation 1.7.0 crashes Logic Pro X
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Legacy Collection
View previous topic :: View next topic  
Author Message
MrKoala



Joined: 03 Aug 2013
Posts: 3

PostPosted: Sat Aug 03, 2013 7:08 pm    Post subject: Wavestation 1.7.0 crashes Logic Pro X Reply with quote

Hello,

Since I installed the Wavestation Legacy 1.7.0, I have a random crash while opening Logic Pro X : it states the Wavestation module caused Logic to terminate unexpectedly.

[img]http://www.isothesis.com/images/crash_logic.tiff[/img]

Here's a screenshot of the error I get (sorry for the French but that's pretty clear anyway).

Oddly, Logic's AU Manager says the plugin is Wavestation 1.3.0. I've never had this early version installed.

I use Logic Pro X (10.0.1) with OSX 10.8.4 on a MacBook Pro 6,2. It seems I now have the same problem while opening Logic Pro 9.

Thanks in advance for any help Smile
_________________
www.soundcloud.com/isothesis
Back to top
View user's profile Send private message Visit poster's website
MrKoala



Joined: 03 Aug 2013
Posts: 3

PostPosted: Sun Aug 04, 2013 1:30 am    Post subject: Reply with quote

Here's the crashed thread :


Process: Logic Pro X [236]
Path: /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X
Identifier: com.apple.logic10
Version: 10.0.1 (2911.42)
Build Info: MALogic-2911042000000000~1
App Item ID: 634148309
App External ID: 15875534
Code Type: X86-64 (Native)
Parent Process: launchd [151]
User ID: 501

PlugIn Path: /Library/Audio/Plug-Ins/VST/KORG/WAVESTATION.vst/Contents/MacOS/WAVESTATION
PlugIn Identifier: jp.co.korg.wavestation_vst
PlugIn Version: 1.7.0 (1.7.0)

Date/Time: 2013-08-03 10:22:14.456 +0200
OS Version: Mac OS X 10.8.4 (12E55)
Report Version: 10

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000c16dbee8

VM Regions Near 0xc16dbee8:
-->
__TEXT 0000000100dbd000-0000000101c2e000 [ 14.4M] r-x/rwx SM=COW /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 jp.co.korg.wavestation_vst 0x000000011ba25402 0x11b961000 + 803842
1 jp.co.korg.wavestation_vst 0x000000011ba25a2c 0x11b961000 + 805420
2 jp.co.korg.wavestation_vst 0x000000011ba2dae8 0x11b961000 + 838376
3 jp.co.korg.wavestation_vst 0x000000011ba1727f 0x11b961000 + 746111
4 jp.co.korg.wavestation_vst 0x000000011b9625ac 0x11b961000 + 5548
5 jp.co.korg.wavestation_vst 0x000000011ba30e4d 0x11b961000 + 851533
6 jp.co.korg.wavestation_au 0x000000011b8c0e94 KLLVSTPlugin::CreateAEffectFromVSTPluginFile(FSRef const&, bool&, __CFBundle*&, int&, __CFString const*) + 226
7 jp.co.korg.wavestation_au 0x000000011b8c02f6 KLLVSTPlugin::LoadVSTPlugin(FSRef const&, __CFString const*) + 70
8 jp.co.korg.wavestation_au 0x000000011b8c0261 KLLVSTPlugin::KLLVSTPlugin(KLLVSTPluginDescriptor const&, int, __CFString const*) + 205
9 jp.co.korg.wavestation_au 0x000000011b8b8f89 KLWrapperBase::CreateVSTInstanceFromVSTPlugin(__CFBundle*, int) + 777
10 jp.co.korg.wavestation_au 0x000000011b8b9f2e KLAUWrapper::Initialize() + 92
11 jp.co.korg.wavestation_au 0x000000011b8cccae AUBase::DoInitialize() + 24
12 jp.co.korg.wavestation_au 0x000000011b8d0f7f AUBase::ComponentEntryDispatch(ComponentParameters*, AUBase*) + 71
13 jp.co.korg.wavestation_au 0x000000011b8be371 ComponentEntryPoint<KLAUWrapper>::Dispatch(ComponentParameters*, KLAUWrapper*) + 107
14 com.apple.audio.toolbox.AudioToolbox 0x00007fff842f96ce _AT_AudioUnitInitialize + 142
15 com.apple.music.apps.MAAudioEngine 0x000000010452e640 CMDAudioUnit::Load(long, long, long) + 3680
16 com.apple.music.apps.MAAudioEngine 0x00000001044b34e4 MD::NewPlug(CPlugIn**, short, long, long, long, bool) + 484
17 com.apple.logic10 0x0000000100ec4c15 0x100dbd000 + 1080341
18 com.apple.logic10 0x0000000100dfe568 0x100dbd000 + 267624
19 com.apple.logic10 0x0000000100dfccd4 0x100dbd000 + 261332
20 com.apple.logic10 0x0000000100df6679 0x100dbd000 + 235129
21 com.apple.logic10 0x0000000100de7858 0x100dbd000 + 174168
22 com.apple.logic10 0x00000001015153d6 0x100dbd000 + 7701462
23 com.apple.logic10 0x0000000100dc10ba 0x100dbd000 + 16570
24 com.apple.logic10 0x0000000100f35836 0x100dbd000 + 1542198
25 com.apple.logic10 0x0000000100f85135 0x100dbd000 + 1868085
26 com.apple.logic10 0x000000010127418c 0x100dbd000 + 4944268
27 com.apple.logic10 0x0000000101241afc 0x100dbd000 + 4737788
28 com.apple.logic10 0x00000001012463cb 0x100dbd000 + 4756427
29 com.apple.logic10 0x000000010124650d 0x100dbd000 + 4756749
30 com.apple.AppKit 0x00007fff8693c348 -[NSDocument _initWithContentsOfURL:ofType:error:] + 135
31 com.apple.AppKit 0x00007fff8693bff4 -[NSDocument initWithContentsOfURL:ofType:error:] + 262
32 com.apple.AppKit 0x00007fff86d64765 -[NSDocumentController makeDocumentWithContentsOfURL:ofType:error:] + 332
33 com.apple.logic10 0x0000000101356d5e 0x100dbd000 + 5872990
34 com.apple.AppKit 0x00007fff86d6f1f3 -[NSDocumentController(NSDeprecated) openDocumentWithContentsOfURL:display:error:] + 824
35 com.apple.logic10 0x000000010126a0bc 0x100dbd000 + 4903100
36 com.apple.CoreFoundation 0x00007fff8c6f3eda _CFXNotificationPost + 2554
37 com.apple.Foundation 0x00007fff858e67b6 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64
38 com.apple.AppKit 0x00007fff86a2a52d -[NSApplication _postDidFinishNotification] + 292
39 com.apple.AppKit 0x00007fff86a2a266 -[NSApplication _sendFinishLaunchingNotification] + 216
40 com.apple.AppKit 0x00007fff86a27452 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 566
41 com.apple.AppKit 0x00007fff86a2704c -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 351
42 com.apple.Foundation 0x00007fff8590007b -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 308
43 com.apple.Foundation 0x00007fff858ffedd _NSAppleEventManagerGenericHandler + 106
44 com.apple.AE 0x00007fff8adfe078 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 307
45 com.apple.AE 0x00007fff8adfded9 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 37
46 com.apple.AE 0x00007fff8adfdd99 aeProcessAppleEvent + 318
47 com.apple.HIToolbox 0x00007fff82fa1709 AEProcessAppleEvent + 100
48 com.apple.AppKit 0x00007fff86a23836 _DPSNextEvent + 1456
49 com.apple.AppKit 0x00007fff86a22df2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
50 com.apple.AppKit 0x00007fff86a1a1a3 -[NSApplication run] + 517
51 com.apple.AppKit 0x00007fff869bebd6 NSApplicationMain + 869
52 com.apple.logic10 0x0000000101240a69 0x100dbd000 + 4733545
53 com.apple.logic10 0x0000000100dbfc34 0x100dbd000 + 11316
_________________
www.soundcloud.com/isothesis
Back to top
View user's profile Send private message Visit poster's website
Etaoin
Full Member


Joined: 13 Oct 2005
Posts: 104

PostPosted: Mon Aug 19, 2013 7:49 am    Post subject: Reply with quote

According to the plugin path it is trying to open the VST. That can't be right. Logic should use the AU, which is in /Library/Audio/Plug-Ins/Components.
Back to top
View user's profile Send private message
MrKoala



Joined: 03 Aug 2013
Posts: 3

PostPosted: Mon Aug 19, 2013 6:22 pm    Post subject: Reply with quote

Considering that Logic does not need VST, I simply removed the Korg folder containing the Wavestation (/Library/Audio/Plug-Ins/VST). After that, Logic would not load the Wavestation at all, claiming the plug-in does not exist.

This is a bit confusing to me... Does Korg use some kind of a wrapper?
_________________
www.soundcloud.com/isothesis
Back to top
View user's profile Send private message Visit poster's website
kurt



Joined: 10 Jun 2006
Posts: 20

PostPosted: Tue Sep 24, 2013 4:21 am    Post subject: Re: Wavestation 1.7.0 crashes Logic Pro X Reply with quote

MrKoala wrote:
Wavestation 1.3.0.

I use Logic Pro X (10.0.1) with OSX 10.8.4 on a MacBook Pro 6,2.


Same problem here Crying or Very sad

Wavestation 1.3.0 with Logic Pro X 10.0.3 on OSX 10.8.5 on a MacBook 6,1
Back to top
View user's profile Send private message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1502

PostPosted: Tue Sep 24, 2013 7:19 pm    Post subject: Reply with quote

The au is a wrapper around the vst, lots of manufacturers do this.

So deleting the vst is not a good idea, reinstall it again.
Back to top
View user's profile Send private message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1502

PostPosted: Wed Sep 25, 2013 6:11 am    Post subject: Reply with quote

Hi Guys,

Using Logic X 10.0.3, Wavestation 1.7 is working perfectly for me.

If you start a new project and add it does it still crash?

Cheers

Andy
Back to top
View user's profile Send private message
kurt



Joined: 10 Jun 2006
Posts: 20

PostPosted: Wed Sep 25, 2013 10:50 am    Post subject: Reply with quote

wavestation plugin insert normal and playing is no problem.

But when you close the logic pro project and re-open, then the wave-station plugin crashes 7 times of 10 Sad
Back to top
View user's profile Send private message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1502

PostPosted: Wed Sep 25, 2013 11:04 am    Post subject: Reply with quote

I don't get this problem, did your project start out as a different version of Logic or was it created in X?
Back to top
View user's profile Send private message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1502

PostPosted: Wed Sep 25, 2013 11:06 am    Post subject: Reply with quote

I spoke too soon, I just started constantly closing and reloading a project with the Wavestation in it and got it to crash, not as often as yours is but on the 8th or 9th time.
Back to top
View user's profile Send private message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1502

PostPosted: Wed Sep 25, 2013 11:14 am    Post subject: Reply with quote

Well I just spent a futile 10 minutes trying to find a Korg email address for support for the legacy software, anyone any idea of an email?
Back to top
View user's profile Send private message
bakerja



Joined: 15 Jul 2013
Posts: 10
Location: United States

PostPosted: Wed Sep 25, 2013 4:41 pm    Post subject: Reply with quote

product_support@korgusa.com

this one worked for me.
Back to top
View user's profile Send private message
bakerja



Joined: 15 Jul 2013
Posts: 10
Location: United States

PostPosted: Wed Sep 25, 2013 4:43 pm    Post subject: Reply with quote

product_support@korgusa.com

this one worked for me.
Back to top
View user's profile Send private message
BobTheDog
Platinum Member


Joined: 21 May 2007
Posts: 1502

PostPosted: Wed Sep 25, 2013 5:12 pm    Post subject: Reply with quote

Thanks.

I'm not in the USA but I will give it a go.
Back to top
View user's profile Send private message
kurt



Joined: 10 Jun 2006
Posts: 20

PostPosted: Wed Sep 25, 2013 5:18 pm    Post subject: Reply with quote

i have also send an email to support.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Korg Forums Forum Index -> Korg Legacy Collection All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group